Mercurial > urweb
view urweb.ebuild @ 2174:ce312cad5ecd
Use correct OpenSSL thread safety macros on OS X (closes #209)
Create an Autoconf test to determine if pthread_t is a pointer or scalar
type, and use the appropriate CRYPTO_THREADID_set macro based on the
result.
author | Benjamin Barenblat <bbaren at mit.edu> |
---|---|
date | Sun, 20 Sep 2015 17:46:07 -0400 |
parents | 3b57a6ddef1a |
children |
line wrap: on
line source
# Distributed under the terms of the BSD3 license # This file needs to be renamed to something like "urweb-20110917.ebuild", to reflect the Ur/Web version to use. inherit eutils EAPI=3 DESCRIPTION="A domain-specific functional programming language for modern web applications" HOMEPAGE="http://www.impredicative.com/ur/" SRC_URI="http://www.impredicative.com/ur/${P}.tgz" LICENSE="BSD" SLOT="0" KEYWORDS="~amd64 ~x86" IUSE="" DEPEND="dev-lang/mlton dev-libs/openssl" RDEPEND="${DEPEND}" S="${WORKDIR}/urweb" src_unpack() { unpack ${A} } src_configure() { econf || die } src_compile() { emake || die } src_install() { emake DESTDIR=${D} install || die dodoc CHANGELOG || die }