view urweb.ebuild @ 2231:67e801cf42c6

Add missing file.
author Ziv Scully <ziv@mit.edu>
date Wed, 06 May 2015 14:50:55 -0400
parents 3b57a6ddef1a
children
line wrap: on
line source
# Distributed under the terms of the BSD3 license

# This file needs to be renamed to something like "urweb-20110917.ebuild", to reflect the Ur/Web version to use.

inherit eutils

EAPI=3

DESCRIPTION="A domain-specific functional programming language for modern web applications"
HOMEPAGE="http://www.impredicative.com/ur/"
SRC_URI="http://www.impredicative.com/ur/${P}.tgz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-lang/mlton
	dev-libs/openssl"
RDEPEND="${DEPEND}"

S="${WORKDIR}/urweb"

src_unpack() {
	unpack ${A}
}

src_configure() {
	econf || die
}

src_compile() {
	emake || die
}

src_install() {
	emake DESTDIR=${D} install || die
	dodoc CHANGELOG || die
}