diff configure.ac @ 2263:dfadb5effdc0

Merge bbaren's fix for bug 209.
author Ziv Scully <ziv@mit.edu>
date Tue, 13 Oct 2015 14:22:05 -0400
parents ce312cad5ecd
children 4f4ae5c92434
line wrap: on
line diff
--- a/configure.ac	Wed Oct 07 08:58:08 2015 -0400
+++ b/configure.ac	Tue Oct 13 14:22:05 2015 -0400
@@ -112,6 +112,22 @@
    PTHREAD_LIBS=""
 fi
 
+# Check if pthread_t is a scalar or pointer type so we can use the correct
+# OpenSSL functions on it.
+AC_MSG_CHECKING([if pthread_t is a pointer type])
+AC_COMPILE_IFELSE(
+  [AC_LANG_PROGRAM(
+     [[
+#include <pthread.h>
+     ]],
+     [[
+pthread_t a;
+*a;
+     ]])],
+  AC_DEFINE([PTHREAD_T_IS_POINTER], [1], [Define if pthread_t is a pointer.])
+    AC_MSG_RESULT(yes),
+  AC_MSG_RESULT(no))
+
 AC_SUBST(CC)
 AC_SUBST(BIN)
 AC_SUBST(LIB)