diff Makefile.am @ 1520:b5517f47b1f1

Tracking and printing of version numbers (based on a patch by Austin Seipp)
author Adam Chlipala <adam@chlipala.net>
date Tue, 02 Aug 2011 13:33:38 -0400
parents 8524a1709821
children 1c9f8f06c1d6
line wrap: on
line diff
--- a/Makefile.am	Sun Jul 24 15:47:09 2011 -0400
+++ b/Makefile.am	Tue Aug 02 13:33:38 2011 -0400
@@ -4,6 +4,7 @@
 LIB      := @LIB@
 INCLUDE  := @INCLUDE@
 SITELISP := @SITELISP@
+VERSION  := @VERSION@
 
 LIB_UR   := $(LIB)/ur
 LIB_C    := $(LIB)/c
@@ -99,7 +100,7 @@
 uninstall-local: uninstall-local-main uninstall-emacs
 
 package:
-	hg archive -t tgz -X tests /tmp/urweb.tgz
+	hg archive -t tgz -X tests "/tmp/urweb-$(VERSION).tgz"
 
 reauto:
 	-autoreconf