diff configure.ac @ 1441:8524a1709821

'--without-emacs' configure option
author Adam Chlipala <adam@chlipala.net>
date Sun, 20 Mar 2011 13:47:39 -0400
parents 1a78ca089bd0
children 969b90b1f2f9
line wrap: on
line diff
--- a/configure.ac	Sun Mar 20 13:15:11 2011 -0400
+++ b/configure.ac	Sun Mar 20 13:47:39 2011 -0400
@@ -49,6 +49,14 @@
     SITELISP=$prefix/share/emacs/site-lisp/urweb-mode
 fi
 
+AC_ARG_WITH([emacs],
+            [AS_HELP_STRING([--without-emacs],
+              [disable installation of Emacs mode])],
+            [],
+            [with_emacs=yes])
+
+AM_CONDITIONAL(USE_EMACS, test "x$with_emacs" = xyes)
+
 AC_SUBST(BIN)
 AC_SUBST(LIB)
 AC_SUBST(INCLUDE)