diff configure.ac @ 1165:7a17588edbff

'configure' checks for libmhash and MLton
author Adam Chlipala <adamc@hcoop.net>
date Thu, 11 Feb 2010 11:29:36 -0500
parents 15767031950c
children be2ef50780ed
line wrap: on
line diff
--- a/configure.ac	Thu Feb 11 09:10:01 2010 -0500
+++ b/configure.ac	Thu Feb 11 11:29:36 2010 -0500
@@ -5,6 +5,30 @@
 AC_PROG_LIBTOOL()
 AC_CONFIG_MACRO_DIR([m4])
 
+AC_CHECK_LIB(mhash, mhash_get_block_size, [], [echo "You must install libmhash."; exit 1])
+AC_CHECK_HEADER([mhash.h], [], [echo "You must install libmhash dev files."; exit 1])
+
+AC_CHECK_PROG(MLTON, mlton, yes, [])
+
+if test [-z $MLTON]; then
+    echo "You must install MLton."
+    exit 1
+fi
+
+AC_CHECK_PROG(MLLEX, mllex, yes, [])
+
+if test [-z $MLLEX]; then
+    echo "You must install MLton (to get mllex)."
+    exit 1
+fi
+
+AC_CHECK_PROG(MLYACC, mlyacc, yes, [])
+
+if test [-z $MLYACC]; then
+    echo "You must install MLton (to get mlyacc)."
+    exit 1
+fi
+
 if test [$prefix = "NONE"]; then
     prefix=/usr/local
 fi