diff Makefile.am @ 1904:686fa4e7f397

xml/parse: Accept entity files on the command line Signed-off-by: Anders Kaseorg <andersk@mit.edu> --- Makefile.am | 2 +- xml/parse.sml | 4 +--- 2 files changed, 2 insertions(+), 4 deletions(-)
author Anders Kaseorg <andersk@mit.edu>
date Fri, 22 Nov 2013 09:36:14 -0500
parents 1efc2bff56f7
children 0d2fdc2cc46c
line wrap: on
line diff
--- a/Makefile.am	Thu Nov 21 16:36:22 2013 -0500
+++ b/Makefile.am	Fri Nov 22 09:36:14 2013 -0500
@@ -63,7 +63,7 @@
 	$(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
 
 xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
-	xml/parse >xml/entities.sml
+	$^ > $@
 
 xml/parse: xml/parse.sml
 	$(MLTON) $(MLTONARGS) xml/parse.sml