diff configure.ac @ 1474:3d0cc841cafd

Fixes to work nicely with OS X and Clang (thanks to Austin Seipp)
author Adam Chlipala <adam@chlipala.net>
date Fri, 17 Jun 2011 11:52:56 -0400
parents 969b90b1f2f9
children b5517f47b1f1
line wrap: on
line diff
--- a/configure.ac	Wed Jun 15 09:52:06 2011 -0400
+++ b/configure.ac	Fri Jun 17 11:52:56 2011 -0400
@@ -79,6 +79,7 @@
    SQHEADER=sqlite3.h
 fi
 
+AC_SUBST(CC)
 AC_SUBST(BIN)
 AC_SUBST(LIB)
 AC_SUBST(INCLUDE)
@@ -103,6 +104,7 @@
   lib directory:       LIB            $LIB
   include directory:   INCLUDE        $INCLUDE
   site-lisp directory: SITELISP       $SITELISP
+  C compiler:          CC             $CC
   Extra GCC args:      GCCARGS        $GCCARGS  
   Postgres C header:   PGHEADER       $PGHEADER
   MySQL C header:      MSHEADER       $MSHEADER