Mercurial > urweb
comparison urweb.ebuild @ 1442:204ca664b5d6
A Gentoo .ebuild file, based mostly on a contribution by moreilcon
author | Adam Chlipala <adam@chlipala.net> |
---|---|
date | Sat, 26 Mar 2011 13:43:47 -0400 |
parents | |
children | 3b57a6ddef1a |
comparison
equal
deleted
inserted
replaced
1441:8524a1709821 | 1442:204ca664b5d6 |
---|---|
1 # Distributed under the terms of the BSD3 license | |
2 | |
3 # This file needs to be renamed to something like "urweb-20110123.ebuild", to reflect the Ur/Web version to use. | |
4 # It won't work with versions from Ur/Web Mercurial repository snapshots older than this file. | |
5 # (The specific version number referenced above is an example of a version that _won't_ work! | |
6 # There hasn't yet been an official release that will.) | |
7 | |
8 inherit eutils | |
9 | |
10 EAPI=3 | |
11 | |
12 DESCRIPTION="A domain-specific functional programming language for modern web applications" | |
13 HOMEPAGE="http://www.impredicative.com/ur/" | |
14 SRC_URI="http://www.impredicative.com/ur/${P}.tgz" | |
15 | |
16 LICENSE="BSD" | |
17 SLOT="0" | |
18 KEYWORDS="~amd64 ~x86" | |
19 IUSE="" | |
20 | |
21 DEPEND="dev-lang/mlton | |
22 dev-libs/openssl" | |
23 RDEPEND="${DEPEND}" | |
24 | |
25 S="${WORKDIR}/urweb" | |
26 | |
27 src_unpack() { | |
28 unpack ${A} | |
29 } | |
30 | |
31 src_configure() { | |
32 econf || die | |
33 } | |
34 | |
35 src_compile() { | |
36 emake || die | |
37 } | |
38 | |
39 src_install() { | |
40 emake DESTDIR=${D} install || die | |
41 dodoc CHANGELOG || die | |
42 } |